swayidle-rs/shell.nix
2024-08-14 08:25:39 +07:00

8 lines
264 B
Nix

{ pkgs ? import <nixpkgs> { } }:
pkgs.mkShell {
name = "rust-wl-shell";
nativeBuildInputs = [ pkgs.pkg-config ];
buildInputs = [ pkgs.wayland-protocols pkgs.wayland pkgs.systemd ];
LD_LIBRARY_PATH = "${pkgs.wayland-scanner.out}/lib:${pkgs.systemd}/lib";
}