swarmos/shell.nix
2023-12-30 19:02:37 +07:00

25 lines
395 B
Nix

{ pkgs ? import <nixpkgs> { }, lib ? pkgs.lib }:
pkgs.mkShell rec {
name = "rust-env";
nativeBuildInputs = with pkgs; [
pkg-config
rustc
cargo
];
buildInputs = with pkgs; [
openssl
alsa-lib
xorg.libX11
xorg.libXcursor
xorg.libXrandr
xorg.libXi
wayland
libxkbcommon
libGL
];
LD_LIBRARY_PATH = "${lib.makeLibraryPath buildInputs}";
}