hboard/shell.nix

10 lines
299 B
Nix

{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell rec {
name = "shell-rust";
nativeBuildInputs = with pkgs; [ rustc cargo pkg-config ];
buildInputs = with pkgs; [ libxkbcommon ];
LD_LIBRARY_PATH = pkgs.lib.makeLibraryPath buildInputs;
LIBCLANG_PATH = "${pkgs.lib.getLib pkgs.libclang}/lib";
}